To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic


  • *Total Posts: 16431
  • *Total Topics: 2522
  • *Online Today: 7
  • *Most Online: 292
(12. Nov 2016, 09:37:31)
  • *Users: 1
  • *Guests: 0
  • *Spiders: 1
  • *Total: 2

* Calendar

Mo
Tu
We
Th
Fr
Sa
Su
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

Desfase de hora en el Shoutbox

Started by jjbotella, 18. May 2010, 12:56:09

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

jjbotella

18. May 2010, 12:56:09
Hola a todos.

Tengo un problema con el bloque Shoutbox, y es que al publicar un mensaje me marca la hora de la publicación con una diferencia de +5 horas respecto al foro.

En un post del soporte en inglés vi que modificando una línea se corregía el problema, pero en mi caso no es así, de echo mi shoutbox ya venía con ese bug resuelto. Aún así lo intenté poniéndolo con el método anterior y nada, sigue igual.

¿Alguien tiene una solución para esto?

Gracias de antemano.

P.D.: Uso la versión 0.980-1


feline

#1
18. May 2010, 13:34:41
Puede cambiar la línea 114 en el /Sources/PortaMx/Class/shoutbox.php archivo.
buscando:
Code Select

'time' => forum_time(),

sustituir por:
Code Select

'time' => forum_time(false),


Fel
Many are stubborn in relation to the path, a few in relation to the target.

jjbotella

#2
19. May 2010, 15:30:37
Ya probé eso y el resultado es el mismo, sigue con el mismo desfase de hora respecto al foro.

¿Alguna otra idea?

carlosdelarco

#3
16. Jun 2011, 16:40:33
Me apunto al carro, tengo un buen desfase en las horas del servidor y haciendo ese cambio no se apaña  :-\

Mi hora en el servidor es GMT+5 y en Diferencia Global tuve que poner 7 para que me cuadrara con la hora española. Si quito ese 7 el Shoutbox me da la hora correcta, pero entonces me desfasa las horas de los posts  :-\

¿Ideas?

codebirth

#4
23. Jun 2011, 15:38:14
Hola, he probado con PortaMX 1.1 y no tengo ese problema. Si podéis, instalar esa versión a ver si se soluciona.

Saludos

c o d e b i r t h
http://codebirth.com/smf