Unable to load the 'main' template

Started by omen666666, 2011 August 28, 01:08:22 am

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

omen666666

*
2011 August 28, 01:08:22 am Last Edit: 2011 August 31, 07:36:06 pm by feline
SMF 2.0 RC4
Portamx 0.99

Hi guys, just done a WHM\CPanel site to site copy to my new host and I get the following error message:

An Error has occured.
Unable to load the 'main' template

This is on the landing page of my site  http://www,domain.com/forum/index.php

All other parts of the forum appear fine.  I have tried to recreate the Front Page block to no avail, same when I have made it inactive.  I have also compared the index.php with the one on the "old" server just incase but no change.

I have tried to uninstall v0.99 in order to install Portamx 1.41 but the uninstall has errors - name with index.php subs.php.  I am not good at amending .php files so did not go through the part where it shows you what to do.  I went ahead with the uninstall but this threw up an error and I could not access my site due toa  few lines in the index.php.  Just thought I would give that a go as some packages you can get away with uninstalling like that although not recommended.

Just in the process of copying it back over again from the old site to try again.  Would be helpful if you could assist as my host is expensive and I am leaving them at the end of august so need to get the site transferred by then

Thanks in advance

Feline

*
#1
2011 August 28, 03:46:40 pm
First update your Forum to SMF 2.0 final, then install PortaMx 1.41
Many are stubborn in relation to the way, but less in relation to the target.

omen666666

*
#2
2011 August 28, 03:59:51 pm
Thanks Feline.  I have tried to upgrade to RC5 over night but that just loses my themes.

I will upgrade to 2.0 Final and I thought I had to uninstall PortaMx 0.99 in order to upgrade to v1.41? 

Feline

*
#3
2011 August 28, 04:07:07 pm
Yes .. older versions as 1.0 must uninstall before.
Many are stubborn in relation to the way, but less in relation to the target.

omen666666

*
#4
2011 August 30, 09:12:28 pm
Hi Feline, I have tried to upgrade to 2.0 Final which poses no problems.  I see this in turn uninstalls the PortaMx 0.99 mod.  I delete this then from packages and then install but I cant access my forum then.

I am using a custom theme the SMF Curve theme.  Due to time constraints I have had to move the forum to the new host as it ends tomorrow.  I still have this issue. 

When I was looking at this issue again at the weekend , I copied over my Themes, Sources and Packages directory and it went away. No problems.  Now it has come to moving the forum to a new host tonight I have again copied these folders over but it hasnt worked this time and I still get the error.

The error only appears on the PortaMx Front Page of my website nowhere else.  Would be grateful for some help as it is generating loads of errors.
It is the same as this website I found whilst googling the error
http://trst.ugngames.net/

Thanks

Feline

*
#5
2011 August 30, 09:33:49 pm
Seems like the boardurl is not correct ...
If I click in the home button. I see the url http://ugngames.net/trst/
Many are stubborn in relation to the way, but less in relation to the target.

omen666666

*
#6
2011 August 31, 06:10:58 am
Hi Feline, That is not my website was ust an example I found.

Anyway I found out what it was it is the DNS propogation.

Once completed my front page reappeared.  As my ISP was pointing to the old site I was viewing the new host via IP address.  y viewing the forum by IP it was showing the unable to Load main template error.  ONce propogation had taken place it was back.  Must be something in PortaMx's .php and index.php that uses the websites DNS name

Feline

*
#7
2011 August 31, 07:36:44 pm
Ok ... I mark the topic as solved
Many are stubborn in relation to the way, but less in relation to the target.

* Shouts

Feline
2018 Aug. 21, 08:10:46 pm
Today we update our Forum to the Version 1.45
Feline
2018 Jun. 09, 07:54:13 pm
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
2018 Mar. 28, 11:56:21 am
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
2018 Mar. 17, 10:35:03 pm
PortaMx Forum 1.3
released !

*
Feline
2017 Dec. 10, 04:30:54 am
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2017 Mar. 03, 11:54:35 pm
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
HolidaysDec 16: 3. Advent (de)