To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic


  • *Total Posts: 16430
  • *Total Topics: 2522
  • *Online Today: 5
  • *Most Online: 292
(12. Nov 2016, 09:37:31)
  • *Users: 0
  • *Guests: 0
  • *Spiders: 1
  • *Total: 1

  • *Google

* Calendar

Mo
Tu
We
Th
Fr
Sa
Su
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

I'm getting this error at the top

Started by agent47, 15. Nov 2011, 21:39:52

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

agent47

15. Nov 2011, 21:39:52
I get the following error at the top of the page when I enter a board on my site:

Strict Standards: Only variables should be passed by reference in /xxx/xxx/public_html/Sources/PortaMx/PortaMxSEF.php on line 220

What does this mean and how do I overcome this?

feline

#1
15. Nov 2011, 23:34:43
Seems like a defect file. Replace the file with a copy from the original archive.
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#2
16. Nov 2011, 10:59:15
Not working feline. Still same error. Only when I disable SEF, does the error go away. I don't want to disable it though :(

feline

#3
16. Nov 2011, 11:26:24
Try follow:
Open the file /Sources/PortaMx/PortaMxSEF.php in a editor (like notepad++), go to line 220 and find:
Code Select

$querystring['board'] = current(array_keys($PortaMxSEF['BoardNameList'], current($url_array))) .'.'. $page;


Replace this with:
Code Select

$brdkey = array_keys($PortaMxSEF['BoardNameList'], current($url_array));
$querystring['board'] = current($brdkey) .'.'. $page;
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#4
16. Nov 2011, 11:37:04
Same error :(

feline

#5
16. Nov 2011, 13:24:28
Please attach the modificated file here ...
php version you use?
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#6
16. Nov 2011, 18:57:43
Here you go feline.
BTW I'm also facing another issue with the theme due to PortaMx but I'll open a separate thread for that. I hope at least one of the two issues can be fixed.

[attachment deleted by admin]

feline

#7
16. Nov 2011, 20:20:29
Whitch php version you use?
Whats is the settings of error_reporting in your php.ini?
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#8
16. Nov 2011, 22:37:19
I'm not too sure how to check which PHP version I'm using?
And neither do I understand your second question? Sorry, I'm really bad at this.

feline

#9
17. Nov 2011, 12:47:46
Quote from: agent47 on 16. Nov 2011, 22:37:19
I'm not too sure how to check which PHP version I'm using?
And neither do I understand your second question? Sorry, I'm really bad at this.

Put the attached file to you forum homedir and run it in your browser...

[attachment deleted by admin]
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#10
17. Nov 2011, 15:07:09
Okay so there's a lot of info. You can check it out yourself as I have left the file on the server.
Visit:
Code Select
http://www.superheroalliance.net/phpinfo.php

feline

#11
19. Nov 2011, 18:15:57
If you can't modify your php.ini, contact your hosting to set the php.ini variable display_errors to off
Many are stubborn in relation to the path, a few in relation to the target.

agent47

#12
20. Nov 2011, 00:57:35
So you want me to contact my host and tell them to set the php.ini variable display_errors to off ?
Okay, once my host turns that off, then what do I do?

feline

#13
20. Nov 2011, 15:28:09
Check again if the error occurs ...
Many are stubborn in relation to the path, a few in relation to the target.

star44

#14
30. Dec 2011, 13:48:23
I'm also facing another issue with the theme.