To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic


  • *Total Posts: 16431
  • *Total Topics: 2522
  • *Online Today: 7
  • *Most Online: 292
(12. Nov 2016, 09:37:31)
  • *Users: 1
  • *Guests: 0
  • *Spiders: 1
  • *Total: 2

* Calendar

Mo
Tu
We
Th
Fr
Sa
Su
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

Firefox 8 and the download problem

Started by feline, 20. Nov 2011, 15:40:14

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

feline

20. Nov 2011, 15:40:14 Last Edit: 25. Nov 2011, 13:24:57 by feline
With Firefox 8 (and the new FF 9 alpha) the attachment download don't work.
We found a solution for the problem and will give this to all Member ...

You can download the attached mod (install with the Package manager) or apply the patch manually.

You have to made 2 small modification on the file /Sources/Display.php ...
Find:
Code Select

// Different browsers like different standards...
if ($context['browser']['is_firefox'])
header('Content-Disposition: ' . $disposition . '; filename*="UTF-8\'\'' . preg_replace('~&#(\d{3,8});~e', '$fixchar(\'$1\')', $utf8name) . '"');


Replace with:
Code Select

// Different browsers like different standards...
if ($context['browser']['is_firefox'])
header('Content-Disposition: ' . $disposition . '; filename*=UTF-8\'\'' . rawurlencode(preg_replace('~&#(\d{3,8});~e', '$fixchar(\'$1\')', $utf8name)));


Find:
Code Select

if (empty($modSettings['enableCompressedOutput']) || filesize($filename) > 4194304)
header('Content-Length: ' . filesize($filename));


Replace with
Code Select

header('Content-Length: ' . filesize($filename));


Now the download works also with FF 8 ...

For AevaMedia, see this post: http://www.simplemachines.org/community/index.php?topic=200401.msg3208061#msg3208061

[attachment deleted by admin]
Many are stubborn in relation to the path, a few in relation to the target.

neverhurry

#1
20. Nov 2011, 21:28:16
 :(

Parse error: syntax error, unexpected T_ELSEIF in .../Sources/Display.php on line 1431

feline

#2
21. Nov 2011, 14:20:17
Seems like a not original Display.php .. with a installed PortaMx the line number we make the change is 1470 and 1489
Many are stubborn in relation to the path, a few in relation to the target.

hartiberlin

#3
22. Nov 2011, 17:22:01
Could you please do a modification that could be installed via the package manager
or is this too complicated ?

Then you could also post this fix on the SMF site and it will benefit ALL Firefox users.

Many thanks.

Regards, Stefan.

feline

#4
22. Nov 2011, 18:02:27
The fix is very simple .. and on SMF you find the same information (but not compressed as here)
Many are stubborn in relation to the path, a few in relation to the target.

hartiberlin

#5
22. Nov 2011, 22:53:22
Okay, I have done the fix and it works great !
Many thanks again Feline.

Regards, Stefan.

hartiberlin

#6
25. Nov 2011, 23:12:36
Anscheinend gibt es doch noch Probleme:

Hallo Stefan
normal verwende ich Opera, doch beim erneuten Versuch bekam ich mit Opera auch wieder diese Sicherheitsmeldung.
Dann habe ich Firefox verwendet und bekomme nachfolgende Trashresponse:
Der Thread hat sich nicht verändert.
Warning: require(/mounted-storage/homexxx/sub0234/sc14534-xxxx/overunity/cache/data_b9e6072fedf0cd62c40796dc1366ca09-SMF-modSettings.php) [function.require]: failed to open stream: No such file or directory in /mounted-storage/home83c/sub001/sc11940-GNVW/overunity/Sources/Load.php on line 2713

Fatal error:  require() [function.require]: Failed opening required '/mounted-storage/homexxx/sub0234/sc14534-xxxx/overunity/cache/data_b9e6072fedf0cd62c40796dc1366ca09-SMF-modSettings.php' (include_path='.:/usr/share/php5/') in /mounted-storage/homexxx/sub0234/sc14534-xxxx/overunity/Sources/Load.php on line 2713


==========

Was kann das sein ?

Er wollte 2 jpg Bilder mit seinem Posting hochladen ...

Danke.

Gruss, Stefan.

feline

#7
27. Nov 2011, 14:32:52
Lösch mal den filecache ...
Many are stubborn in relation to the path, a few in relation to the target.

marco

#8
15. Dec 2011, 13:10:52
Hi all :)

I have the index.php attachment problem.

I have SMF 2.0.1 wit FF 8 and this pakages:

Code Highlighting    0.7.4    [ Uninstall ] [ List Files ] [ Delete ]
2.    Vote polls with points    0.1.3    [ Install Mod ] [ List Files ] [ Delete ]
3.    InLine Attachments    1.11    [ Install Mod ] [ List Files ] [ Delete ]
4.    Attachments in Topics    1.0    [ List Files ] [ Delete ]
5.    Login Security    1.0.2.2    [ Uninstall ] [ List Files ] [ Delete ]
6.    Member Awards    2.2.3    [ Install Mod ] [ List Files ] [ Delete ]
7.    PNG Message Icons    1.3.1    [ Uninstall ] [ List Files ] [ Delete ]
8.    Send Locked Topics To Bottom    1.0    [ Uninstall ] [ List Files ] [ Delete ]
9.    Aeva ~ Auto-Embed Video & Audio    7.2    [ Uninstall ] [ List Files ] [ Delete ]
10.    Drafts

I have modify the Display.php and disinstall aeva but the error is still there.

I don't understund how I can resolve this problem.

Thank you very much for your help and sorry for my bad english.

Cheers ;)

PS: I don't have this file for modification: sources/aeva-gallery.php

feline

#9
15. Dec 2011, 13:18:12
Apply the mod they I have attached in the first post.
For Aeva follow the link I posted ...
Many are stubborn in relation to the path, a few in relation to the target.

XHIBIT

#10
05. Mar 2012, 08:39:35
Does this patch work for FF10 also ?

feline

#11
05. Mar 2012, 17:59:19
Yes .. works  ;)
Many are stubborn in relation to the path, a few in relation to the target.

hartiberlin

#12
21. Apr 2012, 01:10:17
War dieser Fix dafür da, Bilder als Attachments zu posten ?

oder war er für was anderes ?


Brauche ich den auch bei Firefox 11 und bei IE9 ?

Danke.

feline

#13
21. Apr 2012, 13:16:43
Das fix ist NUR für Firefox und den Download, egal was. Das hat nichts mit Bildern zu tun ...
Many are stubborn in relation to the path, a few in relation to the target.

Fisch.666

#14
31. Jan 2014, 18:02:34
Hi,

just a short note:

If you want to install SMF 2.0.7 remove this fix before applying the update to SMF 2.0.7 as the update will conflict with the first change made in the Display.php.

Chappy

28. Jan 2016, 13:46:53 Last Edit: 06. Jun 2016, 19:35:32 by Chappy
Quote from: Fisch.666 on 31. Jan 2014, 18:02:34
Hi,

just a short note:

If you want to install SMF 2.0.7 remove this fix the bathmate results before applying the update to SMF 2.0.7 as the update will conflict with the first change made in the Display.php.


Oh God, this makes it even more confusing. I don't want to mess everything up so is there some video or tutorial on how to do the updates with this fix so as not to lose my SMF board altogether?

feline

#16
28. Jan 2016, 22:48:19
this fix is outdated .. do not use this..
Many are stubborn in relation to the path, a few in relation to the target.