Adk Blog 3.0 - not work

Started by Argon2, 2017 February 14, 08:20:42 pm

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Argon2

*
2017 February 14, 08:20:42 pm Last Edit: 2017 July 03, 05:06:15 pm by Argon2
I have installed mod Adk Blog 3.0 - Does not work.
http://custom.simplemachines.org/mods/index.php?mod=2611
---------
I set:
SMF 2.0.13,
PortaMx-SEF 1.54,
Avatars on Board/MessageIndex,
Sitemap.
---------
I have tried everything but I am obviously doing something wrong.
In advance thank you.

When I navigate to "My blog" : .../index.php?blog=1 ==> ////blog/1/ The screen flashes.

SEF Manager ==> Enable/disable the SEF engine:
Actions they ignored: ==> sitemap,blog,blogadmin

I press the button on the "Blog". The screen flashes.

My .htaccess :

SMF 2.0.13 + PortaMx-SEF 1.54

Feline

*
#1
2017 February 14, 08:35:46 pm
I don't know these mod (adk blog), so I can't nothing say.

For our SEF you need this in the .htaccess ...
Code Select

# sef engine
# -- RewriteBase /forum/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]


And the link http://qrz.center/index.php?blog=1 is not a action !!!
If this ALLWAYS blog=1 then you can use the SEF settings Parts of a URL they ignored:

The other .htaccess setting .. hmm .. I can't say to this.
Many are stubborn in relation to the way, but less in relation to the target.

Argon2

*
2017 February 14, 10:19:21 pm Last Edit: 2017 July 03, 05:08:21 pm by Argon2
index.php

uninstall PortaMX - mod Adk Blog 3.0 WORK.
install PortaMX - mod Adk Blog 3.0 NOT WORK.
SEF Manager PortaMX ==> disable.
???

Test Forum.
////test1/index.php?action=blogs
My blog ==> ////test1/index.php?blog=1 not work.



SMF 2.0.13 + PortaMx-SEF 1.54

Feline

*
#3
2017 February 16, 09:05:20 pm
The problem is the link index.php?blog=1 ...
That is no action for smf and the portal simple think, it's a bad portal request.

if the link allways blog=1 then .. then you can that add in the portal setting ...

Request names they handled as Forum request: -> blog=1

But .. you can add more blog=? in this settings like: blog=1,blog=2,blog=3 ....

More is not possible ...
Many are stubborn in relation to the way, but less in relation to the target.

Argon2

*
2017 May 04, 06:32:06 am Last Edit: 2017 July 03, 05:05:25 pm by Argon2
///
SMF 2.0.13 + PortaMx-SEF 1.54

Feline

*
#5
2017 May 04, 01:37:59 pm
I just tested that on your site ...

If I request ?action=blogs  I see this:

*

then I click on the last entry  (the link is index.php?blog=1;sa=topic;id=1)
But this is a bad link (missing the action=xxx) and our Portal think the boardindex in meaning.

So if the author of this mod use SMF compatible links, it works also with our Portal ..

Our Portal Mod do this, so we have no options in this problem.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

Argon2

*
2017 May 04, 02:27:34 pm Last Edit: 2017 July 03, 05:05:41 pm by Argon2
Quote from: feline, 2017 May 04, 01:37:59 pmthen I click on the last entry  (the link is index.php?blog=1;sa=topic;id=1)
But this is a bad link (missing the action=xxx) and our Portal think the boardindex in meaning.

So if the author of this mod use SMF compatible links, it works also with our Portal ..

Our Portal Mod do this, so we have no options in this problem.

Fel
.../555/index.php?blog=1;sa=cat;id=1 Wrong link for portal.

.../555/index.php?action=blogs;blog=1;sa=cat;id=1  Link of this kind should be?
SMF 2.0.13 + PortaMx-SEF 1.54

Feline

*
#7
2017 May 04, 03:28:28 pm
Quote from: Argon2, 2017 May 04, 02:27:34 pmhttp://qrz.center/555/index.php?action=blogs;blog=1;sa=cat;id=1  Link of this kind should be?
No .. this don't work .. but this MUST works, becuse that is the correct link.
Like SMF .. ?action=xyz or ?topic=nn or ?board=nn
Without a action the portal think it's a board or topic request.

We have a (very old) Blog Modification they work correctly with any other modification, because we USE allways the ?action=xxx for any request to our Blog Modification. But this Mod is not full compatible with smf 2.0.13  ???
It works but can install only on SMF 2.0.11 ... after the installation you can upgrade SMF to 2.012 and then to 2.013 ...
So I can't give any help for this problem ...
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#8
2017 May 04, 04:20:05 pm
I just tested our Blog Modification with a fresh SMF 2.0.13 ... works Perfect.
This Mod works also with our Portal.
I add this to the download section, so if you want, you can test this ...
Many are stubborn in relation to the way, but less in relation to the target.

Argon2

*
#9
2017 May 04, 04:37:36 pm
Quote from: feline, 2017 May 04, 04:20:05 pmI just tested our Blog Modification with a fresh SMF 2.0.13 ... works Perfect.
This Mod works also with our Portal.
I add this to the download section, so if you want, you can test this ...
Thank you. But the file can not be downloaded.
https://www.portamx.com/dlattach/id/3526/fld/19/
404 File Not Found
SMF 2.0.13 + PortaMx-SEF 1.54

Feline

*
#10
2017 May 04, 08:23:10 pm
Sorry .. my fault .. I forgot to set the proper permissions  :(
Many are stubborn in relation to the way, but less in relation to the target.

* Shouts

Feline
2018 Aug. 21, 08:10:46 pm
Today we update our Forum to the Version 1.45
Feline
2018 Jun. 09, 07:54:13 pm
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
2018 Mar. 28, 11:56:21 am
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
2018 Mar. 17, 10:35:03 pm
PortaMx Forum 1.3
released !

*
Feline
2017 Dec. 10, 04:30:54 am
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2017 Mar. 03, 11:54:35 pm
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
HolidaysDec 16: 3. Advent (de)