PortaMx v1.3 developed

Started by Feline, 7 years ago

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
7 years ago
PortaMx v1.3 is a update for PortaMx v1.0 / v1.1 / v1.2. This release fixed all known bugs we found.
The archive contains a update for v1.0, v1.1, v1.1 and a full install package.
PortaMx releases older then 1.0 must uninstall before.

Fixes and changes:
# request a child category from a category with show subcats failed if show subcats is not set on the child category
# on print screen the portamx.css is not loaded
+ added get_title function and get_article function
+ added board selection for promotedposts
+ allowed empty for sef_spacechar
# show/hide block on theme/on language don't work correct
# error if SD removed and SD standalone set
Many are stubborn in relation to the way, but less in relation to the target.

yocks

*
#1
7 years ago
How to update ?
I am using 1.2  ???

Comadevil

*
#2
7 years ago
Quote from: yocks, 7 years ago
How to update ?
I am using 1.2  ???


See OP
QuoteThe archive contains a update for v1.0, v1.1, v1.1 and a full install package.
PortaMx releases older then 1.0 must uninstall before.


Just install it

yocks

*
#3
7 years ago
Thanks for ur reply comadevil.

Just place the folder in package directory ?
do smf will trace it automatically ?

I nvr update so far the php applications and new to php.
:)

yocks

*
#4
7 years ago
Ahh... I hv successfully upgraded  O0

I can see the upgrade option in package manager once i uploaded the directory.

Thanks.

Feline

*
#5
7 years ago
yea .. this is allays the same if a new PortaMx version released  ;)
Also ... in the PortaMx Admin Center you see follow is a new version available:
Version information
Installed PortaMx version: 1.2
Current PortaMx version: 1.3
Install now !
Download the current version

If you click on Install now ! the package is download to your server and after short time you see this:

Package has been downloaded successfully
    PortaMx 1.3             [ List Files ] [ Install Mod ]

:D
Many are stubborn in relation to the way, but less in relation to the target.

yocks

*
#6
7 years ago
Ohhh... there is another way from protamx admin center gud. I got it.
Thanx for ur information.


And after update to 1.3 something strange is happening for me...  ???

I can see everywhere the recent post in front page community and in all pages.
I can't disable it from block manager ;)

Feline

*
#7
7 years ago
Quote from: yocks, 7 years ago
I can see everywhere the recent post in front page community and in all pages.
I can't disable it from block manager ;)

Sorry .. but i understand not what you mean ...
Many are stubborn in relation to the way, but less in relation to the target.

yocks

*
#8
7 years ago
Quote from: feline, 7 years ago
Quote from: yocks, 7 years ago
I can see everywhere the recent post in front page community and in all pages.
I can't disable it from block manager ;)

Sorry .. but i understand not what you mean ...

Hey before in V1.2 I have setup the recent post only for my front page.
After I upgrade to V1.3 the recent post appears everywhere.
I mean it appears in frontpage, community, topic etc and also in admin panel.
I was unable to disable it from block manager. It never works.

Now I over ride this problem.

I deleted the recent post block in block manager and I re-created the recent post.
And makes it appear only in front page. Now it works normal.  O0

Thanks once again.

MiY4Gi

*
#9
7 years ago
Thanks for your hard work. This is just what I needed.  O0

Quote from: yocks, 7 years ago
Hey before in V1.2 I have setup the recent post only for my front page.
After I upgrade to V1.3 the recent post appears everywhere.
I mean it appears in frontpage, community, topic etc and also in admin panel.
I was unable to disable it from block manager. It never works.

Now I over ride this problem.

I deleted the recent post block in block manager and I re-created the recent post.
And makes it appear only in front page. Now it works normal.  O0

Thanks once again.


That would be a result of the block manage being updated/corrected. You probably didn't empty your browser cache and delete old cookies after the installation.
Check out my new anime club. Discuss and share anime, or just fool around with other forumites. Join us at MyAnimeClub.

yocks

*
#10
7 years ago
Quote from: MiY4Gi, 7 years ago
That would be a result of the block manage being updated/corrected. You probably didn't empty your browser cache and delete old cookies after the installation.

May be u r right. These thing nvr sparks in ma mind  ;D

mikeymx5

*
#11
7 years ago
I have had it with portamx...... uninstalling it deleted all my custom CSS files.

My god this is a admins nightmare to do any updates not to mention all the other problems it causes.

Feline

*
#12
7 years ago
That is a MUST if you will have a approve by SMF for a mod.
Uninstall have to remove ALL files and folder ...

And on any update, all files are replaced by newer  ...
Many are stubborn in relation to the way, but less in relation to the target.

mikeymx5

*
#13
7 years ago
If you expect people to use features like custom CSS, or the Editor uploads portamx should never delete these or over write them. If it does that just bad coding.

I have gotten to the point where I dont fear updating my SMF version but i do fear I will have to update portamx in the process.

Sorry you have done alot of work here that I respect but untill you improve on the installer I have no choice but to move to another portal.

Guest

*
#14
7 years ago
Ok I have to make a comment here. I updated fine to 1.3, no problems at all with the 'recent posts' block.

Well done Feline ;D

Feline

*
#15
7 years ago
Quote from: mikeymx5, 7 years ago
If you expect people to use features like custom CSS, or the Editor uploads portamx should never delete these or over write them. If it does that just bad coding

If you use the SAMPLES they we delivered, then it's your problem. ANY software overwrites exist files on Update because many things are changed. And I do not like people who think they know everything better ...
Many are stubborn in relation to the way, but less in relation to the target.

lordi

*
#16
7 years ago
well done feline, thanks
portaMX developing progress are really fast, now 1.3 are released , wow



mikeymx5

*
#17
7 years ago
Sorry frustrated after my second upgrade where I lost data.

My main gripe was that you gave us the option of using custom CSS on blocks, but to do so you have to edit PMX files before PMX can see you added it. Trust me I did some research on the website before I used the feature.

The problem is that every time I move versions such as .9 to 1.0 I have to uninstall PMX and it deletes the folders that contain post install data files.

I instead have created a css file and just point to it with in my block. Clumsy but gets the job done and I don't have to be concerned if a update will delete it. This goes the same for the editor upload folder, luckily I didn't have a problem with it this time.

Other than that my painful 2.0 upgrade is complete and I have calmed down.

Good job on all the other fixes and the portal but please fix the installers/uninstallers.

mikeymx5

*
#18
7 years ago
Quote from: yocks, 7 years ago
Quote from: feline, 7 years ago
Quote from: yocks, 7 years ago
I can see everywhere the recent post in front page community and in all pages.
I can't disable it from block manager ;)

Sorry .. but i understand not what you mean ...

Hey before in V1.2 I have setup the recent post only for my front page.
After I upgrade to V1.3 the recent post appears everywhere.
I mean it appears in frontpage, community, topic etc and also in admin panel.
I was unable to disable it from block manager. It never works.

Now I over ride this problem.

I deleted the recent post block in block manager and I re-created the recent post.
And makes it appear only in front page. Now it works normal.  O0

Thanks once again.


I didnt have a problem with the Recent post but I did with all my settings getting reset to defaults? They must not be kept in the database. Such as PMX permissions.

I also had a problem with my blocks showing on all pages. Anyway I had to go to each block and reset the visibility settings. I think if I remember correctly it had something to do with the Show Hide Block on theme over writes the location visibility settings. Probably a bug but I only use one theme now so I didn't need it and thus didn't look further into it.

Feline

*
#19
7 years ago
We chnaged the database tables up from 1.0 RC so if you have a older Version installed the data is partial droped or overwritten. The 1.3 installer have a bug and it's don't convert older tables, he drops the blocks table.
And that files are overwritten on install a new release is absolutely normal.
All I can say to this is  ... Backup any data before update.
Many are stubborn in relation to the way, but less in relation to the target.

mikeymx5

*
#20
7 years ago
I think I upgraded from 1.0rc3 or rc4? to 1.3 final after the smf 2.0 upgrade.

And yes I had a back up, but unfortunately I didn't back up the /theme/default/portamx/blockcss/ folder as I don't use the default theme and i forgot that I added a customblock.mpt that would of needed to be backed up.

Its water under the bridge at this point, and I didn't mean to get on your (Do not Like list), I just wish that I didn't have to worry about the installer dropping tables, or deleting folders that may contain important data. Something has happened on my last three PMX updates that has made me spend hours fixing files or the database.

Anyway nuff said about it all.

mikeymx5

*
#21
7 years ago
I think I found a PortaMX theme bug, I will have to look into it more and see if I can find what needs to be corrected.

This view is correct
http://houstonmiataclub.com/index.php?cat=ArticlesHome;child=Jeffs_Blog

But this view breaks the theme at the very bottom of the articles.
http://houstonmiataclub.com/index.php?cat=Jeffs_Blog

Look like a missing close divide.

I think it is missing a </div> just after
Code Select
<span class="botslice"><span></span></span>

BTW I like the articles menu is showing sub categories now :).

Feline

*
#22
7 years ago
We will look at that and fixed in the next release ...
Many are stubborn in relation to the way, but less in relation to the target.

mikeymx5

*
#23
7 years ago
One more bug, if I select a block to show or hide on a theme it will over ride the show hide block on action setting and show up every where.

Feline

*
#24
7 years ago
The bug is known and fixed for v1.4
Many are stubborn in relation to the way, but less in relation to the target.

* Shouts

Feline
8 months ago
Today we update our Forum to the Version 1.45
Feline
11 months ago
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
a year ago
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
a year ago
PortaMx Forum 1.3
released !

*
Feline
a year ago
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2 years ago
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31