PortaMx v1.0 RC4 released

Started by Feline, 8 years ago

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
8 years ago Last Edit: 8 years ago by feline
The PortaMx corp. released the version 1.0 RC4 for SMF 2.0 RC4 / RC5 (and we hope) the last RC before v1.0 becomes gold.
This is a update for v1.0 RC1, RC2, RC3, RC3.1 and a full install.
If you have a older release (like v0.990) installed, this must uninstall these before.

Steps to update your forum to SMF 2.0 RC5

1.. Make a backup of all files in the forum
2.. Backup you database
3.. Uninstall PortaMx .. this is absolutely necessary !
4.. install the SMF 2.0 RC5 large upgrade
5.. install PortaMx v1.0 RC4

If you have any problem after the installation, please check if all correct installed and that all files and folder exist before you call our support.
Many are stubborn in relation to the way, but less in relation to the target.

Cool

*
#1
8 years ago
hmmm...download and test
|I Use: SMF 2.0.5 | PortaMx 1.51
Q: What do you do when you see a bear in the woods?
A: Play Dead!
H-A-H-L = Happy Admins Have Linux

grandgaffar

*
#2
8 years ago
many thanks i test it now 100%

Feline

*
#3
8 years ago
The admin menu is inserted after 'sub_buttons' => 'featuresettings', which exists on a unmoded SMF.
If that not exists or changed the routine fails.
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#4
8 years ago
Okay, I have it working at Ruhleben.com

Now I am going to test a few other MODs with it,

Many thanks.

Regards, Stefan.

b4pjoe

*
#5
8 years ago
Quote from: bancherd, 8 years ago
Thank you Fel, for looking into my problems.  :)

Here are more information.  If frontpage is set to be shown, the tabs disappeared.  If NO frontpage, the tabs reappeared, but "admin" only has two options.

First picture is right after install, second picture is when NO frontpage was to be shown, third picture shows the limited admin's options available when NO frontpage was to be shown, and the last picture again shows what happened when frontpage was set to be shown again.

I do not know what the problem is, it could be my ISP.  I am at a loss.  :(


I've seen the same thing on my home test server running CentOS but it works fine on my live site. I think it must be a server configuration problem of some type.

b4pjoe

*
#6
8 years ago
Quote from: feline, 8 years ago
The PortaMx corp. released the version 1.0 RC4 for SMF 2.0 RC4 / RC5 (and we hope) the last RC before v1.0 becomes gold.
This is a update for v1.0 RC1, RC2, RC3, RC3.1 and a full install.
If you have a older release (like v0.990) installed, this must uninstall these before.

Steps to update your forum to SMF 2.0 RC5

1.. Make a backup of all files in the forum
2.. Backup you database
3.. Uninstall PortaMx .. this is absolutely necessary !
4.. install the SMF 2.0 RC5 large upgrade
5.. install PortaMx v1.0 RC4

If you have any problem after the installation, please check if all correct installed and that all files and folder exist before you call our support.


Is re-saving all the blocks again required after installing PMX 1.0 RC4?

Cool

*
#7
8 years ago

Quote from: bancherd, 8 years ago

I've seen the same thing on my home test server running CentOS but it works fine on my live site. I think it must be a server configuration problem of some type.


had the same on a centos server wich i setup. may i can test more on this next week.
|I Use: SMF 2.0.5 | PortaMx 1.51
Q: What do you do when you see a bear in the woods?
A: Play Dead!
H-A-H-L = Happy Admins Have Linux

Feline

*
#8
8 years ago
Quote from: bancherd, 8 years ago
Here are more information.  If frontpage is set to be shown, the tabs disappeared.  If NO frontpage, the tabs reappeared, but "admin" only has two options

I can't reproduce that on all my system ..
You use SMF RC5 and you are sure that all PortaMx files have the correct version?
Without look at you server (ftp & admin= i can say nothing about this.

Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#9
8 years ago
Quote from: bancherd, 8 years ago
If it is of any use, on both ISP's that have this problem, the forum-firewall mod warned me that "magic_quotes" are on.  ???

This should be set to off in the php.ini
magic_quotes_gpc = Off
magic_quotes_runtime = Off
Many are stubborn in relation to the way, but less in relation to the target.

bla.blub

*
#10
8 years ago
installed it on my smf rc5 /pmx rc3.1 and everything worked fine  O0

Feline

*
#11
8 years ago
Quote from: bancherd, 8 years ago
If it is of any use, on both ISP's that have this problem, the forum-firewall mod warned me that "magic_quotes" are on.  ???

Your problem (missing menu buttons) is depended on the php version ..
To split of and insert the additional button we use the construct
array_merge(
  array_splice(parts before),
  array(additional buttons),
  array_splice(parts after)
)
Normaly this is not critical. but array_splice works very different on php 4, 5.0.x and up from 5.2.x
With php 5.2.x the value NULL is the same a not given value, because php 5.0.x interpret that as a empty value (0)  :(
That is not documented in all the php docs ..
On you server (php 5.0.x) I see this problem and I have made a simple fix for that.

For all other user they have this problem, we will develop a small patch for this ..

Fel
Many are stubborn in relation to the way, but less in relation to the target.

bla.blub

*
#12
8 years ago
glad to hear that, because of some scripts i can´t switch from 5.0x -> 5.3 but the missing buttons in the admin menu was not really a problem for me.

Feline

*
#13
8 years ago
Quote from: bla.blub, 8 years ago
glad to hear that, because of some scripts i can´t switch from 5.0x -> 5.3

What type of scripts you mean? normally all scripts work on higher php versions ...
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#14
8 years ago
Quote from: bancherd, 8 years ago
Once things settled down on my sites, I'll definitely become a charter member.  :)

Well .. any donation or CM help us  :)
Many are stubborn in relation to the way, but less in relation to the target.

bla.blub

*
#15
8 years ago
Quote from: feline, 8 years ago
Quote from: bla.blub, 8 years ago
glad to hear that, because of some scripts i can´t switch from 5.0x -> 5.3

What type of scripts you mean? normally all scripts work on higher php versions ...


the onlineshop (not smf related) its a modded xt commerce.

* Shouts

Feline
a year ago
Today we update our Forum to the Version 1.45
Feline
a year ago
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
a year ago
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
a year ago
PortaMx Forum 1.3
released !

*
Feline
a year ago
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2 years ago
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30