PortaMx v1.0 RC3 released to public.

Started by Feline, 8 years ago

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
8 years ago
PortaMx v1.0 RC3 with a full featured Category / Article management and Search Engine Friendly url's (SEF) option developed to public.

This release is a update for v1.0 RC1 / v1.0 RC2 and a full install. If you have a older release installed, this must deinstall before.

Download your copy now and find out all the new features and function ...

Fel
Many are stubborn in relation to the way, but less in relation to the target.

becometa

*
#1
8 years ago
Finally!
well done!  :D

and fel, update your signature on smf.org  ;)

jan.s

*
#2
8 years ago
Hello
something went wrong.
When i try to access the page, i get this in the error.log:
Code Select
PHP Parse error:  syntax error, unexpected '&', expecting T_VARIABLE or '$' in /var/www/html/m.net/Sources/PortaMx/LoadData.php on line 1062,

Feline

*
#3
8 years ago
php version you use?
Many are stubborn in relation to the way, but less in relation to the target.

jan.s

*
#4
8 years ago
Hello
just looked it up
4.4.8
seems a bit old?

mikeymx5

*
#5
8 years ago
Quote from: jan.s, 8 years ago
Hello
something went wrong.
When i try to access the page, i get this in the error.log:
Code Select
PHP Parse error:  syntax error, unexpected '&', expecting T_VARIABLE or '$' in /var/www/html/m.net/Sources/PortaMx/LoadData.php on line 1062,


got same refreshed the browser and tried the install again and it installed but it deleted all my Right side blocks... Im getting a bit tired of not being able to trust any upgrades.

Also I was getting a White Screen of Death in AEVA. Uninstalling .990 fixed it and it is now working after V1 was installed so little bad and a little good came from this.

So two things
Figure out why this keeps deleting my PHP blocks and make the uninstall not delete the editor_upload folder.

jan.s

*
#6
8 years ago
Hello
i deleted the & in "foreach($cats as &$cat)"

now the page is loaded again.
but my admin-menue is broken
it ends with the pmx chapter

something is messed up in the admin area :(

bla.blub

*
#7
8 years ago
Hi,

Updatet from 0.990 -> 1.0 RC3 everthing wend fine  ;D

Calender is working fine (is there a way to change "first day of the week -> Wednesday"?)
SEF is not working (empty page and no errors @ log) but thats not really important for me so i don´t care.

Thanks for all your time and effords.

Regards Peter

jarska

*
#8
8 years ago
Quote from: jan.s, 8 years ago
Hello
i deleted the & in "foreach($cats as &$cat)"

now the page is loaded again.
but my admin-menue is broken
it ends with the pmx chapter

something is messed up in the admin area :(


Same thing happens here. :(

russena

*
#9
8 years ago
Update  to new version


Many thanks for the new release.

What steps do I switch from SMF 2.0 RC3 | SMF PortaMx v0.980-1 to 2.0 RC4 | v1.0 RC3?


Can I update  using the following version of the gallery:
Aeva Media 1.3a © noisen  / smf-media
<u>Basile</u>
Ho sempre pensato che la scuola fosse fatta prima di tutto dagli insegnanti. In fondo chi mi ha salvato dalla scuola se non tre o quattro insegnanti? [Daniel Pennac]

jacoatnos

*
#10
8 years ago
Hi

I am getting this error when installing the new version: Fatal error: Call to undefined function portamx()

b4pjoe

*
#11
8 years ago
Quote from: russena, 8 years ago
Update  to new version


Many thanks for the new release.

What steps do I switch from SMF 2.0 RC3 | SMF PortaMx v0.980-1 to 2.0 RC4 | v1.0 RC3?


Can I update  using the following version of the gallery:
Aeva Media 1.3a © noisen  / smf-media


When you do the RC3 ===> RC4 upgrade it will remove all of your mods. Once you have RC4 installed you then need to install the new version of PortaMx. Don't forget to open and re-save ALL of your blocks after installing the new version of PortaMx.

The latest version of the free AEVA is 1.4c. I would recommend using it instead of the older 1.3a version.

b4pjoe

*
#12
8 years ago
Quote from: jacoatnos, 8 years ago
Hi

I am getting this error when installing the new version: Fatal error: Call to undefined function portamx()


Your SMF version is RC4 correct? I believe it has to be to install the latest version of PortaMx.

When you start to install it does it list any errors in the files before you start the installation? Does it complete the installation and give you that error when you try to load your forum?

Feline

*
#13
8 years ago
Quote from: jan.s, 8 years ago
Hello
just looked it up
4.4.8
seems a bit old?

very old, yes .. laatest php 4 was 4.4.9 i think.
And .. you can't simple remove the &, because this is a reference to the variable and this is absolute necessary else the function don't work.
But .. I will try a look at the problem.
Many are stubborn in relation to the way, but less in relation to the target.

jarska

*
#14
8 years ago
Quote from: jarska, 8 years ago
Quote from: jan.s, 8 years ago
Hello
i deleted the & in "foreach($cats as &$cat)"

now the page is loaded again.
but my admin-menue is broken
it ends with the pmx chapter

something is messed up in the admin area :(


Same thing happens here. :(


And the right block in the forum dont work either..

Feline

*
#15
8 years ago
Quote from: mikeymx5, 8 years ago
So two things
Figure out why this keeps deleting my PHP blocks and make the uninstall not delete the editor_upload folder.

Send my a mysql export from you portamx blocks table BEFORE the update, so I can check that.
About the editor_upload folder .. I say always make a copy before  ;)

Fel
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#16
8 years ago
Quote from: bla.blub, 8 years ago
Calender is working fine (is there a way to change "first day of the week -> Wednesday"?)

No, that is't possible, only saturday, sunday, monday.
Quote
SEF is not working (empty page and no errors @ log) but thats not really important for me so i don´t care.

You have a correct .htaccess and your http server supports modrewrite?

Fel
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#17
8 years ago
Quote from: russena, 8 years ago
Update  to new version

What steps do I switch from SMF 2.0 RC3 | SMF PortaMx v0.980-1 to 2.0 RC4 | v1.0 RC3?

download the large update from SMF and install it. (Make backups of all files/folder and the database before).
The upgrade remove all installed mods, but not the tables.
If the forum works, you can install portamx 1.0

Quote
Can I update  using the following version of the gallery:
Aeva Media 1.3a © noisen  / smf-media

There is a 1.4 exist i mean ans this works with PortaMx as well

Fel
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#18
8 years ago
Quote from: jacoatnos, 8 years ago
I am getting this error when installing the new version: Fatal error: Call to undefined function portamx()

Look with ftp on you server and verify that all files and folder exist..
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#19
8 years ago
Quote from: jarska, 8 years ago
And the right block in the forum dont work either..

If you have dynamic visibility settings, these must corrected.
ALWAYS you have to check and correct all blocks after a release change...
Many are stubborn in relation to the way, but less in relation to the target.

jarska

*
#20
8 years ago
Quote from: feline, 8 years ago
Quote from: jarska, 8 years ago
And the right block in the forum dont work either..

If you have dynamic visibility settings, these must corrected.
ALWAYS you have to check and correct all blocks after a release change...


Yes, I know that and do that every time I update portamx, but now its not working right.

Right block works only every page, not just forum, even I set visibility settings correct.

And admin panel not work right either, ends to the portamx.

Feline

*
#21
8 years ago
Quote from: jarska, 8 years ago
Right block works only every page, not just forum, even I set visibility settings correct.

Here is the fix for that: https://www.portamx.com/bug-reports/portamx-v10-rc3-small-bug/msg13076/#msg13076
Quote
And admin panel not work right either, ends to the portamx.

I can't see any problem here, works as well on all my systems

Fel
Many are stubborn in relation to the way, but less in relation to the target.

jacoatnos

*
#22
8 years ago
Quote from: feline, 8 years ago
Quote from: jacoatnos, 8 years ago
I am getting this error when installing the new version: Fatal error: Call to undefined function portamx()

Look with ftp on you server and verify that all files and folder exist..


Yip that was the issue, glitch with extracting the files, but now i am getting this on top of the page:
"Notice: Undefined index: integrate_pre_load"

Has something to do with this line
Quoteif(strpos($modSettings['integrate_pre_load'], 'pmxsef_convertSEF') !== false)
in PortaMxLoader.php

jarska

*
#23
8 years ago
Quote from: feline, 8 years ago
And admin panel not work right either, ends to the portamx.

I can't see any problem here, works as well on all my systems

Fel


Here is two pictures what happend when I install Portamx RC3 , another forum still have Portamx RC2 and works.

Admin buttons for modifications and service, ect..disappear:



[attachment deleted by admin]

Bugo

*
#24
8 years ago
AdminSettings.english.php and other language files:
Code Select

* @Version: 1.0 RC3
* @Date: 10.02.2001

Back to the past... 2001 :)

* Shouts

Feline
5 months ago
Today we update our Forum to the Version 1.45
Feline
8 months ago
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
10 months ago
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
10 months ago
PortaMx Forum 1.3
released !

*
Feline
a year ago
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
a year ago
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28