PortaMx v0.952 released

Started by Feline, 2008 December 03, 12:34:32 am

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
2008 December 03, 12:34:32 am Last Edit: 2009 January 10, 11:14:34 pm by feline
This is a upgrade package for v0.947, v0.950, v0.951 and also a full install package.

These changes we made since version 0.951

Fixes:

  • HTML Validation errors on Block overview, Admin PHP Block, Admin Script block

  • CSS Validation error for filter:alpha (need only for IE, removed)

  • Theme change and language change not works with prettyurl

  • Blocktitles with single/double quotes gives javascript error

  • Duplicate "style" definition

  • Teaser wordcount on thai characters returns bad result

  • On edit/create a post, the ctrl-arrow keys handled by xBarKeys

  • Duplicate input field on cbt_navigator

  • cvt_navigator collapse/expand kick the view up to the top of the page

  • A lot of code optimize


News:

  • Custom action to hide each panel

  • Inner padding on each block (space between frame and content)

  • New language file (UserBlocks.lang.php) added.
       This file is used for custom blocks to add the block description

  • Added action handling for SMF Project Tools 0.1.2a



Language files other the english and german must be update for this release.
Follow strings are new and must be add and translate:
AdminSettings.english.php:
Code Select
$txt['pxm_settings_panel_customhide'] = 'Hide the panel on action:';
$txt['pmx_settings_panel_custhelp'] = 'Here you can enter any other actions, separated by a comma.';


AdminBlocks.english.php:
Code Select
$txt['pxm_edit_innerpad'] = 'Inner padding:';
$txt['pmx_pixel'] = ' Pixel';


Fel
Many are stubborn in relation to the way, but less in relation to the target.

antechinus

*
#1
2008 December 03, 01:51:45 am
Good stuff. I'll run a test installation using Codebirth's permissions when I get time tonight. 
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

Feline

*
#2
2008 December 03, 01:54:38 am
I have just updated the topic for this install methode !
Two more Folder/files to change ..

Fel
Many are stubborn in relation to the way, but less in relation to the target.

fords8

*
#3
2008 December 03, 03:05:43 am
Anyone having a issue with setting up blocks to show only on the frontpage? The Global Panel settings on the PortaMx Settings panel seems to be working fine. But when I make a block and try to set to frontpage only, the blocks still show up on all pages. And before I go digging, I want to make sure it is just me.

antechinus

*
#4
2008 December 03, 03:42:27 am
I haven't tested it yet. I wont have time to set it up for another five hours at least.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

fords8

*
#5
2008 December 03, 03:53:27 am
Quote from: antechinus, 2008 December 03, 03:42:27 am
I haven't tested it yet. I wont have time to set it up for another five hours at least.


It's all good! Just didn't want to have to do a bunch of extra work if everyone was having a problem.

antechinus

*
#6
2008 December 03, 06:27:29 am
I'll throw it on my local in a couple of hours and test that first.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

fords8

*
#7
2008 December 03, 06:40:36 am
Quote from: antechinus, 2008 December 03, 06:27:29 am
I'll throw it on my local in a couple of hours and test that first.


I am sure I will be off to bed by that time. But post up what you come up with and I will have a look in the morning at it.

antechinus

*
#8
2008 December 03, 08:17:07 am
It works. I suspect you just got mixed up. "Hide" isn't the default setting for that window. The default setting is "Show".
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

fords8

*
#9
2008 December 03, 09:10:15 am
Tomorrow I will have a look at it after some sleep. But I set the blocks the same way I did before.

antechinus

*
#10
2008 December 03, 09:17:16 am
Well 0.952 went in without any problems on my local and my online server. Online it threw some "failed to open stream" and "not a valid stream resource" errors but they don't appear to have been serious and the error log is clear now. They were related to the classic and babylon themes, so there may be a missing image in there somewhere but I haven't checked.

Seems to be fine.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

Feline

*
#11
2008 December 03, 09:28:07 am
Ahhh ... I copy a "forum" button to classic and babylon theme.
I think, this can be removed fom the installer.
If anyone use this themes, him can copy these images manually.

Fel

Edit:
I moved the Classic and Babylon "forum" images to separate folder in the archive (classic / babylon)
Many are stubborn in relation to the way, but less in relation to the target.

edi67

*
#12
2008 December 03, 10:25:17 am
excellent update done without problem ;) bravo feline  ;)

Feline

*
#13
2008 December 03, 10:36:25 am
Thanks ..
and a click on the donate botton would help also  ;)

Fel
Many are stubborn in relation to the way, but less in relation to the target.

codebirth

*
#14
2008 December 03, 05:12:52 pm
Thanks. Smooth upgrade to v0.952 :)

c o d e b i r t h
http://codebirth.com/smf

Cool

*
#15
2008 December 03, 05:13:31 pm
update went fine without any problems
|I Use: SMF 2.0.5 | PortaMx 1.51
Q: What do you do when you see a bear in the woods?
A: Play Dead!
H-A-H-L = Happy Admins Have Linux

fords8

*
#16
2008 December 04, 02:34:19 am
Ok, I had to uninstall all the mods I had installed on the site. Reinstalled the portal and it was still doing it. Uninstalled it again and went and did a database clean up. I got rid of all the extra stuff in the database. Reinstalled the portal and now it is working good.

BTW, after I uninstalled the portal and reinstalled it, all the blocks I had made before the uninstall came back. I did not see anything in the database for the portal after I uninstalled it. Not sure what was storing the block data at that point.

O well! My mistake was uninstalling the portal and try installing the new release. I should have just let it upgrade instead. I always have to do things the hard way. LOL!

Feline

*
#17
2008 December 04, 10:09:59 am
Quote from: fords8, 2008 December 04, 02:34:19 am
BTW, after I uninstalled the portal and reinstalled it, all the blocks I had made before the uninstall came back. I did not see anything in the database for the portal after I uninstalled it. Not sure what was storing the block data at that point.

While delete database tables are not more a part of SMF's approve process,  I have removed that.
So it's easier to Upgrade/Reinstall the mod.
The archive contains a script (dbremove.php) to remove the PortaMx tables if it's necessary.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

Powerbob

*
#18
2008 December 05, 09:17:59 am
Update done, went without a hitch. Congratulations 8)
*
My test Site;http://pplb.net/smf21/index.php
It's nice to be nice :)

67Marine

*
#19
2008 December 05, 03:18:28 pm
:D I am using SMF 2.0.4 for one of my forums and was in need of a good portal.  Simple loaded with errors on a new installation of the SMF, EZPortal shrunk my useful page too much, Tiny is out of date and doesn't support, Geno is "Oh No",...  Was getting very frustrated until i loaded and flew with this Mod - Kudo's for a job well done....

www.1MAR.67Marine.com 


PS I love the capability of making items active/inactive without deleting and having to re-do...

funcouldron

*
#20
2008 December 09, 10:31:42 am
The package you tried to upload either is not a valid package or has become corrupted.

Feline

*
#21
2008 December 09, 07:51:20 pm
You are using SMF 2.0 beta 4 ?

Fel
Many are stubborn in relation to the way, but less in relation to the target.

funcouldron

*
#22
2008 December 09, 08:10:55 pm
yeh

Feline

*
#23
2008 December 09, 08:30:18 pm
Quote from: funcouldron, 2008 December 09, 08:10:55 pm
yeh

The archive is ok?
You can unpack that manually?
If not, clear your browser cache and repeat the download.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

funcouldron

*
#24
2008 December 09, 09:06:07 pm
still same error

* Shouts

Feline
2018 Aug. 21, 08:10:46 pm
Today we update our Forum to the Version 1.45
Feline
2018 Jun. 09, 07:54:13 pm
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
2018 Mar. 28, 11:56:21 am
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
2018 Mar. 17, 10:35:03 pm
PortaMx Forum 1.3
released !

*
Feline
2017 Dec. 10, 04:30:54 am
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2017 Mar. 03, 11:54:35 pm
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
HolidaysDec 16: 3. Advent (de)