To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic

  • *Total Posts: 14944
  • *Total Topics: 2271
  • *Online Today: 10
  • *Most Online: 292
(2016 November 12, 09:37:31 am)

PortaMx v0.957 released

Started by feline, 2009 March 15, 02:43:05 pm

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

feline

2009 March 15, 02:43:05 pm
Just we released the version 0.957 of PortaMx  8)

This version is a update for version 0.955, 0.956 and also a full install package.
Up from v0.955 you see the new releases in your PortaMx Adminitration Center and can install this release directly.

Please note that you have to unistall version older then 0.955 before you apply this release.
The blockstable from v0.952 will be converted to the new version, the settings table is overwritten.
For older releases as 0.952 you MUST DROP THE PORTAMX TABLES !

After successfully installation, you have to check and correct all Setting and your block settings.

You can update your installed languages in the Language Manager after installation of v0.957

Good luck  :)

Fel

--------------------------------
Version: 0.957 (15.03.2009)

   Fixes:
      ! custom actions values dont matched correctly if a space added
      ! PHP and SCRIPT block strips html content if a "<textarea>" tag used
      ! a lot of typos and smaller bugs removed

   News:
      + Shout box block added
      + Language handling redesigned for more flexiblility
      + A lot of code optimize and removing SMF2 beta 4 code
      + Boardnews and New_post block redesigned, to rescale or remove "inline" Images.
         On rescale, the Images can see in the HighSlide viewer as fullsize.
      + All HighSlide popup window now centered.
      + Added a setting to ignore request like Singlepage request (zCommunity use this)
      + Blocktype names now shown in translated language
      + Added a settings "Disable Highslide on action" (for SMF Media Gallery and other)
Many are stubborn in relation to the path, a few in relation to the target.

feline

#1
2009 March 15, 04:34:49 pm
Quote from: digiscrap ,  2009 March 15, 04:14:13 pm
But, I dont see a 'Install' button for the 0.957 language.

You see the language update button after v0.957 is installed ...

Fel
Many are stubborn in relation to the path, a few in relation to the target.

feline

#2
2009 March 15, 05:12:22 pm
After update to v0.957 go to the Language manager and you see that as I attched.

Fel

[attachment deleted by admin]
Many are stubborn in relation to the path, a few in relation to the target.

feline

#3
2009 March 15, 05:34:57 pm
You have PortaMx installed with the packed Manager?
If not your forum do not work correct, because a database update is absolutly necessary !

By the way .. I just see, that the UTF8 version of dutch language is not complete .. a lot of Blocks files missing, so I have removed them from language server.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

andu

#4
2009 March 16, 12:29:38 am
Wonderfull.. This is Great!!  :D

antechinus

#5
2009 March 16, 12:48:32 am
Awesomesauce. ;D  I'll get this sucker running right now. Thanks, Fel. 
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

Tyrsson

#6
2009 March 16, 12:49:48 am
You guys ROCK!!!

antechinus

#7
2009 March 16, 01:22:19 am
One question: are there any additions to the list in this post? https://www.portamx.com/
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

feline

#8
2009 March 16, 01:44:42 am
Quote from: antechinus ,  2009 March 16, 01:22:19 am
One question: are there any additions to the list in this post? https://www.portamx.com/

No .. only the manualy install instruction I must update. For 0.957 is a modifiction on the Subs.php changed.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

antechinus

#9
2009 March 16, 02:01:21 am
Ok. massive fail.

Went through those permissions carefully. Created a temp folder set to 777. Uploaded 957 to Packages. Pre-installation test showed no problems.

Fatal error after installation. The script did not create the Sources/PortaMx folder or the files it contains.  

ETA: Just checked and it did not create any PortaMx folders at all. Anywhere. Looks like it's back to the drawing board.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#10
2009 March 16, 02:41:16 am
Goes in fine on my local host. No luck online though. Package manager problem again.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#11
2009 March 16, 03:15:40 am
Ok, got it sorted. The file and database changes were done. The only problem was the PortaMx folders and their contents not being created by the package manager. I did an installation on my local host, then uploaded them to my server.

There's some broken code in the head somewhere though. Same on this site and on Tyrsson's installation. You can see the effect at the top left here.

Code Select
L<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

QuoteCharacter not allowed in prolog


Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

feline

#12
2009 March 16, 03:22:02 am
replace the two files the I have posted in the v0.957 "small update" message.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

antechinus

#13
2009 March 16, 03:31:11 am
I downloaded the archive long after you posted those files. It looks like the archive may not have updated correctly. Suggest doing it again to make sure.

ETA: Found another problem. This one is minor but should be fixed anyway. The script appears to create an empty folder called  \  in every PortaMx folder. They are created with 555 permissions.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#14
2009 March 16, 03:42:06 am
Quote from: feline ,  2009 March 16, 03:22:02 am
replace the two files the I have posted in the v0.957 "small update" message.

Fel

Done that. The broken head code is still there.

ETA: Oh and some of the css appears to be broken on the SMF Core theme when viewing the forum in Opera 9.6.
Specifically, I think there is a problem with the smalltext classes.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

DirtRider

#15
2009 March 16, 11:30:20 am
Great stuff Fel the install went off 100%. Just one thing I did look but I don't see anything on this. How do I get my smilies to show in the BBC display like you have them here  :-\

Just another issue where does it take the time from for the shout as my one is completely out showing March 17, 2009, 01:48:14 AM when it is March 16, 2009 , 01:30:00 PM
"The real question is not whether machines think but whether men do. "


feline

#16
2009 March 16, 02:00:21 pm
Quote from: digiscrap ,  2009 March 16, 10:25:53 am
I have a small problem with the HS viewer:

+ Added a settings "Disable Highslide on action" (for SMF Media Gallery and other)

When putting 'gallery' in the input box I still get an error in the gallery. When disabling HS overall the error disappears. Does this mean that the problem is in Gallery (NOT mGallery) or isn't the disable function working correctly? When using the lightbox function in the Gallery the error also disappears (but I dislike Lightbox).

Please give me a admin account and a ftp accout to your server, so I can test that. PM me ..

Fel
Many are stubborn in relation to the path, a few in relation to the target.

feline

#17
2009 March 16, 02:05:52 pm
Quote from: DirtRider ,  2009 March 16, 11:30:20 am
Great stuff Fel the install went off 100%. Just one thing I did look but I don't see anything on this. How do I get my smilies to show in the BBC display like you have them here  :-\

Just another issue where does it take the time from for the shout as my one is completely out showing March 17, 2009, 01:48:14 AM when it is March 16, 2009 , 01:30:00 PM

The shoutbox can only use the smileys as developed with portaMx.
But you can replace the smileys in the folder Smileys/PortaMx with yours. (you have to use same names and same count of smileys)

The time in the Shoutbox is your forum time as given from SMF.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

DirtRider

#18
2009 March 16, 02:05:54 pm
Only my admin can see the shout box none of the members can see it. I have all the groups selected in the "Select the user groups they can shout"

Fel I don't see any smilies at all but this may also be related to the above as well
"The real question is not whether machines think but whether men do. "


feline

#19
2009 March 16, 02:09:58 pm
Quote from: DirtRider ,  2009 March 16, 02:05:54 pm
Only my admin can see the shout box none of the members can see it. I have all the groups selected in the "Select the user groups they can shout"

You have set the Block visibility access settings ?

The one is  who can shout, the other who can see  ;)

Fel
Many are stubborn in relation to the path, a few in relation to the target.

DirtRider

#20
2009 March 16, 02:19:21 pm
Ooops sorry  :-[ I missed that they can now see it and shout but we still don't see any smilies at all in the BBC display box
"The real question is not whether machines think but whether men do. "


DirtRider

#21
2009 March 16, 02:30:14 pm
Fel now I have a problem. I have just tried uninstalling the upgrade mod and my forum has crashed

Warning: require_once(/home/davem/public_html/Sources/PortaMx/PortaMx.php) [function.require-once]: failed to open stream: No such file or directory in /home/davem/public_html/index.php on line 68

Fatal error: require_once() [function.require]: Failed opening required '/home/davem/public_html/Sources/PortaMx/PortaMx.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/davem/public_html/index.php on line 68

Can you please have a look at this for me I will give you FTP to my site
"The real question is not whether machines think but whether men do. "


feline

#22
2009 March 16, 02:52:56 pm
Why you uninstall PortaMx ?

Ok now ..

Simple replace follow files on your server from the SMF 2.0 RC1 install archive:

    * index.php
    * SSI.php
    * Sources/Admin.php
    * Sources/Display.php
    * Sources/Errors.php
    * Sources/Load.php
    * Sources/ManageMaintenace.php
    * Sources/ManagePermissions.php
    * Sources/ModerationCenter.php
    * Sources/Security.php
    * Sources/Subs.php
    * Sources/Subs-Boards.php
    * Themes/default/scripts/xml_topic.js
    * Themes/babylon/style.css

If you have other mods installed they have modified one of these files, then you have the mods uninstall before and reinstall after.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

DirtRider

#23
2009 March 16, 02:55:40 pm
Quote from: feline ,  2009 March 16, 02:52:56 pm
Why you uninstall PortaMx ?

Ok now ..

Simple replace follow files on your server from the SMF 2.0 RC1 install archive:

    * index.php
    * SSI.php
    * Sources/Admin.php
    * Sources/Display.php
    * Sources/Errors.php
    * Sources/Load.php
    * Sources/ManageMaintenace.php
    * Sources/ManagePermissions.php
    * Sources/ModerationCenter.php
    * Sources/Security.php
    * Sources/Subs.php
    * Sources/Subs-Boards.php
    * Themes/default/scripts/xml_topic.js
    * Themes/babylon/style.css

If you have other mods installed they have modified one of these files, then you have the mods uninstall before and reinstall after.

Fel


I wanted to install the full install and not teh upgrade to see if I could get my smilies to work
"The real question is not whether machines think but whether men do. "


DirtRider

#24
2009 March 16, 02:58:21 pm
Fel I don't see this folder that you are talking about. How much will you charge me to fix this please .
"The real question is not whether machines think but whether men do. "