To use this website completely, it is necessary to store cookies on your computer.
 

* Statistic

  • *Total Posts: 16399
  • *Total Topics: 2548
  • *Online Today: 10
  • *Most Online: 292
(2016 November 12, 09:37:31)
  • *Users: 0
  • *Guests: 0
  • *Spiders: 2
  • *Total: 2

  • *Yahoo!
  • *Baidu

PortaMx v0.957 released

Started by feline, 2009 March 15, 14:43:05

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

feline

2009 March 15, 14:43:05
Just we released the version 0.957 of PortaMx  8)

This version is a update for version 0.955, 0.956 and also a full install package.
Up from v0.955 you see the new releases in your PortaMx Adminitration Center and can install this release directly.

Please note that you have to unistall version older then 0.955 before you apply this release.
The blockstable from v0.952 will be converted to the new version, the settings table is overwritten.
For older releases as 0.952 you MUST DROP THE PORTAMX TABLES !

After successfully installation, you have to check and correct all Setting and your block settings.

You can update your installed languages in the Language Manager after installation of v0.957

Good luck  :)

Fel

--------------------------------
Version: 0.957 (15.03.2009)

   Fixes:
      ! custom actions values dont matched correctly if a space added
      ! PHP and SCRIPT block strips html content if a "<textarea>" tag used
      ! a lot of typos and smaller bugs removed

   News:
      + Shout box block added
      + Language handling redesigned for more flexiblility
      + A lot of code optimize and removing SMF2 beta 4 code
      + Boardnews and New_post block redesigned, to rescale or remove "inline" Images.
         On rescale, the Images can see in the HighSlide viewer as fullsize.
      + All HighSlide popup window now centered.
      + Added a setting to ignore request like Singlepage request (zCommunity use this)
      + Blocktype names now shown in translated language
      + Added a settings "Disable Highslide on action" (for SMF Media Gallery and other)
Many are stubborn in relation to the path, a few in relation to the target.

feline

#1
2009 March 15, 16:34:49
Quote from: digiscrap ,  2009 March 15, 16:14:13
But, I dont see a 'Install' button for the 0.957 language.

You see the language update button after v0.957 is installed ...

Fel
Many are stubborn in relation to the path, a few in relation to the target.

feline

#2
2009 March 15, 17:12:22
After update to v0.957 go to the Language manager and you see that as I attched.

Fel

[attachment deleted by admin]
Many are stubborn in relation to the path, a few in relation to the target.

feline

#3
2009 March 15, 17:34:57
You have PortaMx installed with the packed Manager?
If not your forum do not work correct, because a database update is absolutly necessary !

By the way .. I just see, that the UTF8 version of dutch language is not complete .. a lot of Blocks files missing, so I have removed them from language server.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

andu

#4
2009 March 16, 00:29:38
Wonderfull.. This is Great!!  :D

antechinus

#5
2009 March 16, 00:48:32
Awesomesauce. ;D  I'll get this sucker running right now. Thanks, Fel. 
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

Tyrsson

#6
2009 March 16, 00:49:48
You guys ROCK!!!

antechinus

#7
2009 March 16, 01:22:19
One question: are there any additions to the list in this post? https://www.portamx.com/
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

feline

#8
2009 March 16, 01:44:42
Quote from: antechinus ,  2009 March 16, 01:22:19
One question: are there any additions to the list in this post? https://www.portamx.com/

No .. only the manualy install instruction I must update. For 0.957 is a modifiction on the Subs.php changed.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

antechinus

#9
2009 March 16, 02:01:21
Ok. massive fail.

Went through those permissions carefully. Created a temp folder set to 777. Uploaded 957 to Packages. Pre-installation test showed no problems.

Fatal error after installation. The script did not create the Sources/PortaMx folder or the files it contains.  

ETA: Just checked and it did not create any PortaMx folders at all. Anywhere. Looks like it's back to the drawing board.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#10
2009 March 16, 02:41:16
Goes in fine on my local host. No luck online though. Package manager problem again.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#11
2009 March 16, 03:15:40
Ok, got it sorted. The file and database changes were done. The only problem was the PortaMx folders and their contents not being created by the package manager. I did an installation on my local host, then uploaded them to my server.

There's some broken code in the head somewhere though. Same on this site and on Tyrsson's installation. You can see the effect at the top left here.

Code Select
L<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

QuoteCharacter not allowed in prolog


Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

feline

#12
2009 March 16, 03:22:02
replace the two files the I have posted in the v0.957 "small update" message.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

antechinus

#13
2009 March 16, 03:31:11
I downloaded the archive long after you posted those files. It looks like the archive may not have updated correctly. Suggest doing it again to make sure.

ETA: Found another problem. This one is minor but should be fixed anyway. The script appears to create an empty folder called  \  in every PortaMx folder. They are created with 555 permissions.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.

antechinus

#14
2009 March 16, 03:42:06
Quote from: feline ,  2009 March 16, 03:22:02
replace the two files the I have posted in the v0.957 "small update" message.

Fel

Done that. The broken head code is still there.

ETA: Oh and some of the css appears to be broken on the SMF Core theme when viewing the forum in Opera 9.6.
Specifically, I think there is a problem with the smalltext classes.
Using Internet Explorer 6 on the internet is like urinating in a public swimming pool.
It's rude, there's no excuse for it, and anyone who does it should be ashamed of themselves.