Fix for PortaMx v0.990 and Aeva embedded

Started by Feline, 2010 November 23, 08:44:37 pm

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
2010 November 23, 08:44:37 pm
The PortaMx corp. developed a small patch to fix the Aeva white screen and PortaMx copyright issue.
Also you have to apply the Patch for the hook integration.
You can download both patches on our Download area (PortaMx for SMF 2.0 RC4)

Fel
Many are stubborn in relation to the way, but less in relation to the target.

b4pjoe

*
#1
2010 November 23, 08:52:12 pm
Fel,

THANK YOU, THANK YOU, THANK YOU!!!

That appears to have fixed the issue.

Feline

*
#2
2010 November 23, 09:11:39 pm
And as I say from begin .. this have to do with the new integration hooks in RC4.
If Aeva make his ob_start, ob_end, the SMF outbuffer is called twice in ONE session, so a dynamic function they is created on the first outbuffer call is exist on the second call. This crashed the entire system.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

atfosan

*
#3
2010 November 23, 09:14:32 pm
Thanks! Is it possible to unite three patches in one? Or when will the new version of PortaMx with all correctives be realesed?
my SMF project with PortaMx - school site.

Feline

*
#4
2010 November 23, 09:17:04 pm
Of course we fix know bugs in any new release.
And the both patches have nothing common . the one is for the entire system the other only for Aeva.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

atfosan

*
#5
2010 November 23, 11:02:23 pm
Quote from: feline, 2010 November 23, 09:17:04 pm
Of course we fix know bugs in any new release.
And the both patches have nothing common . the one is for the entire system the other only for Aeva.

Fel


Ok :) Will be new releases in nearest time? :) Example 0.991 where there are no any problem at all.

And what is the right order in installing Aeva, PortaMx, patches?
my SMF project with PortaMx - school site.

BurakG

*
#6
2010 November 23, 11:24:41 pm
Thanks for the fix Fel, all seems to work fine now.

To tell the truth I was now expecting this, and I am glad I was wrong :)
Destiny. The design is clearly Ancient ..

http://www.mazdaclubtr.com
http://www.subaruclubtr.com

Feline

*
#7
2010 November 23, 11:37:41 pm
Quote from: atfosan, 2010 November 23, 11:02:23 pm
Ok :) Will be new releases in nearest time? :) Example 0.991 where there are no any problem at all.

Not soo near .. we work on the 1.0 and I think this comes with SMF2 gold.
Quote
And what is the right order in installing Aeva, PortaMx, patches?

No order for this.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#8
2010 November 23, 11:43:58 pm
Maybe you can make a sticky posting with all the summary steps and
fixes, that must be applied ?

Many thanks.

Feline

*
#9
2010 November 23, 11:47:39 pm
Onyl the both patches (in any order) thy you can download under PortaMx for SMF2.0 RC4

If you have SimpleSEF installed AFTER PortaMx, you have to remove ob_portamx from the smf_settings table.
(Select * from smf_settings where variable like '%integration%')
That shows all integration hooks ...

Fel
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#10
2010 November 23, 11:54:58 pm
Quote from: feline, 2010 November 23, 11:47:39 pm
Only the 2 patches (in any order) that you can download under PortaMx for SMF2.0 RC4

Fel


Why can´t I just update this inside the PortaMX admin section ?

Do I have to apply these fixes like MODs ,
so I upload them with the package manager ?

Many thanks.

b4pjoe

*
#11
2010 November 24, 12:00:22 am
Quote from: hartiberlin, 2010 November 23, 11:54:58 pm
Quote from: feline, 2010 November 23, 11:47:39 pm
Only the 2 patches (in any order) that you can download under PortaMx for SMF2.0 RC4

Fel


Why can´t I just update this inside the PortaMX admin section ?

Do I have to apply these fixes like MODs ,
so I upload them with the package manager ?


Many thanks.


Yes.

Feline

*
#12
2010 November 24, 12:05:25 am
Quote from: hartiberlin, 2010 November 23, 11:54:58 pm
[Why can´t I just update this inside the PortaMX admin section ?

While this are only patches not regular updates...
QuoteDo I have to apply these fixes like MODs ,
so I upload them with the package manager ?

Download the patches, copy with ftp to your server (in the Packages folder) and install.

Fel
Many are stubborn in relation to the way, but less in relation to the target.

spoogs

*
#13
2010 November 24, 02:16:12 am
Thank you very much for the fix Fel.... I truly appreciate it.

Autopilot

*
#14
2010 November 24, 04:55:44 am
Feline thanks for fixing this problem.

atfosan

*
#15
2010 November 25, 02:46:42 pm
M... It doesn't work for me... Order what I followed:
1) updated forum to 2.0 RC4
2) to Aeva 1.4c
3) PortaMx 0.990
4) Patch for PortaMx v0.990 from download area
5) Patch by Norv https://www.portamx.com/topic_2096.msg12094.html#msg12094
6) BugFix for Aeva

Now I get a blank pages with error in logs
Code Select
[25-Nov-2010 16:27:31] PHP Fatal error:  Cannot redeclare pmxcopyright() (previously declared in /home/user/WWW/Sources/PortaMx/LoadData.php(1572) : eval()'d code:1) in /home/user/WWW/Sources/PortaMx/LoadData.php(1572) : eval()'d code on line 1
my SMF project with PortaMx - school site.

b4pjoe

*
#16
2010 November 25, 04:29:54 pm
There are 2 patches for PortaMx to apply.

atfosan

*
#17
2010 November 25, 04:31:37 pm
I have apply both patches.
my SMF project with PortaMx - school site.

b4pjoe

*
#18
2010 November 25, 04:43:56 pm
I wasn't aware that AEVA 1.4c had been released so I uninstalled 1.4b and installed 1.4c and I'm not getting any white screen issues. Are you only getting them on pages with embedded links? Have you cleared both your browser cache and smf cache after the installs?

atfosan

*
#19
2010 November 25, 04:49:20 pm
Yes I have cleared both caches and yes white pages are only those where there are Aeva copyright.
my SMF project with PortaMx - school site.

Feline

*
#20
2010 November 25, 05:14:02 pm
You are sure, that you have applied the patch for Aeva correctly?
Please look at the file /Sources/PortaMx/LoadData.php, go the the function ob_portamx and look if you found follow:
Code Select
if(!function_exists('pmxCopyRight'))
eval(unhex($context['PortaMx']['keydata']['key']));


Fel
Many are stubborn in relation to the way, but less in relation to the target.

atfosan

*
#21
2010 November 25, 08:30:02 pm
Sorry for disturb - it was a problem with permission again.
Now all including even SimpleSEF works fine! Thanks!
my SMF project with PortaMx - school site.

KB

*
#22
2011 January 04, 03:42:15 am
I would just like to add a note for those running into this issue for the first time recently..
Ive got a RC4 board with PMX 990 and AEVA 14c which was having the white page issue when loading a post with embedded youtube vid link.  I installed only ONE patch tho..and the blank page is fixed, plus the AEVA copyright info is in place when an embedded video is used, but gone on 'normal' posts...as it should be. 
I installed the patch :
Patch to fix the Aeva 1.4b white screen and Copyright issue.
[1.085 Kb]


No other patch was needed for me.

THANKS Fel :) 
You do a great service for all of us.

b4pjoe

*
#23
2011 January 04, 07:47:27 pm
The other patch was for something else. Along with the SMF patch for RC4.

KB

*
#24
2011 January 04, 11:09:11 pm
Yes, I realized that there must have been some other issues issues at the time..but reading along this thread, it still points to installing at least two, if not three patches if you count the one directed to in Norv's link.  I know I missed quite a few things due to my absence (since RC2), and was a bit unsure myself, so figured I would post a recent experience to clarify the procedure for others.

* Shouts

Feline
2018 Aug. 21, 08:10:46 pm
Today we update our Forum to the Version 1.45
Feline
2018 Jun. 09, 07:54:13 pm
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
2018 Mar. 28, 11:56:21 am
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
2018 Mar. 17, 10:35:03 pm
PortaMx Forum 1.3
released !

*
Feline
2017 Dec. 10, 04:30:54 am
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2017 Mar. 03, 11:54:35 pm
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
HolidaysDec 16: 3. Advent (de)