PortaMx-Forum 1.4 released

Started by Feline, 2018 June 13, 10:05:12 pm

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Feline

*
2018 June 13, 10:05:12 pm
This release is full compatible with the EU GDPR,  have a About this site (Impressum) and a Privacy Policy Agreement .

In the Admin part you can setup all the Informations they need for the GDPR and "About this site" functions.
Also we fixed a lot of smaller problem and bugs we found, optimize all the code, changed language strings, css and javascript.

Any registered member must (on the first Login) accept the Policy Agreement else he can't continue.
It's possible, that he go to his profile and request a account removing.
Also he can export his personal data (Profile and Posts).

The Forum Admin then delete the User and all parts they can identify him, will by be removed or changed to "Guest".

NOTE: You (as Admin) must enable the function "Require admin approval when member deletes account" on Admin - Maintenance - Security !!!
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#1
2018 June 14, 06:49:46 pm
Fantastisch. Vielen Dank.
werde gleich runterladen und es testen.
Muss ich auch das Sitemap Plugin erst deinstallieren und das Grüne und Rote Template ?

Feline

*
#2
2018 June 14, 08:49:38 pm
Ja .. sitemap deintallieren und auch die beiden Themen !! Ist sehr wichtig !!!
Dann die Sprache auf Englisch umstellen !!
Backup der Datenbank vorher machen .. auch sehr wichtig !!!

Nun kannst du das Update starten ...

Wenn alles problemlos gelaufen ist, kannst du die Themen und Sitemap von unserem package server runterladen und installieren. (jeweils die Versionen für 1.4)
Many are stubborn in relation to the way, but less in relation to the target.

Feline

*
#3
2018 June 14, 09:32:01 pm
Ich habe mir übrigens mal diesen OpenImporter genauer angesehen ..
Das teil ist sowas von Mist .. man glaubt es kaum. Läuft ewig und drei Tage ..

1. Die Settings zu importieren ist je schon mal der größte Blödsinn. Da werden ja nur alle Settings die PortaMx Forum bei der Installation gemacht geplättet .. das geht dann schon mal in die Hose.
2. Ich weiß nicht warum das Teil ewig Pausen macht und das alle 30 Sekunden. Es gibt eine PHP Variable wie lange ein script laufen darf. Das kann man auslesen und diese Zeit verwenden.
3. Macht der nach jeder Pause eine "restart", was heißt, das im "Was ist fertig" Fenster alles weg ist  :o

Also ich habe das auf meine PortaMx DB eine Stunde laufe lassen .. da war er grad bei den Membern zu gange.
Ok .. mein Laptop ist kein Renner vorm Herrn ... aber DAS geht besser zu machen.

Übrigen .. hast Du mal getestet, ob deine Attachments all da sind und korrekt angezeigt werden ?
Würde mich interessieren .. weil ich da auch noch Probleme sehe ...

Fel
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#4
2018 June 14, 10:28:13 pm
Okay, danke für die Info.
werde ich mal testen...
Wie kann ich das bei über 11.000 Attachments am besten testen ??

Feline

*
#5
2018 June 14, 10:39:14 pm
Jeweils ein paar avatare und attachments ..
Kannst du unter  Admin - Forum - Dateianhänge & Avatare ansehen ...
Dabei mal auf ein Bild klicken und schauen ob es korrekt angezeigt wird.
Bei Files mal sehen ob ein Download funktioniert.
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#6
2018 June 14, 11:00:47 pm
Okay, mache ich alles morgen in Ruhe, muss jetzt bald in die Falle...

Kannst Du denn aus dem gepatchten Importer einen vernünftigen Importer machen ?

Danke.

LG, Stefan.

hartiberlin

*
#7
2018 June 14, 11:25:12 pm
Hmmn, bekomme gerade den Fehler beim update auf 1.4:

Warning: fwrite() expects parameter 1 to be resource, string given in /www/htdocs/xxxxx/overunity.de/upgrade.php on line 551

Warning: fclose() expects parameter 1 to be resource, string given in /www/htdocs/xxxxx/overunity.de/upgrade.php on line 552

Und der Balken bei Progress bleibt bei 0 % stehen...

Kann er sich da nicht eiloggen per FTP ?
passwürter müssten aber eigentlich stimmen...
In meiner Datenbank sind allerdings auch noch die alten
SMF_ Tabellen zusätzlich drinnen,
kann das stören ??
oder kann ich die jetzt rauslöschen ?

hartiberlin

*
#8
2018 June 15, 12:29:21 am
Hmm..da mein Hoster noch unterscheidet,  ob die Permission auf FTP oder Php User gesetzt ist..könnte das sein, dass das Php upgrade.php Script nicht auf den FTP Bereich zugreifen kann ??
Vielleicht stimmt da ne Permission nicht ?

Feline

*
#9
2018 June 15, 02:31:54 am
wofür brauchst du beim Upgrade ftp ???
Das Update script braucht das nicht ...
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#10
2018 June 15, 11:12:23 am
Quote from: feline, 2018 June 15, 02:31:54 amwofür brauchst du beim Upgrade ftp ???
Das Update script braucht das nicht ...
Doch, das upgrade.php  fragt er doch nach den Daten...!!

hartiberlin

*
#11
2018 June 15, 11:26:09 am
Hier fragt er doch gleich nach dem FTP Login...

hartiberlin

*
#12
2018 June 15, 11:32:21 am
Was wird denn da in Zeile 551 und 552 abgefragt ?

Die FTP einlog-Daten ?

Siehe Bild...

Habe alles richtig eingegeben, aber er legt nicht los...
P.S. für den Screenshot habe ich den Usernamen und den Pfadnamen mit xxxxx ausgeixxt..

hartiberlin

*
#13
2018 June 15, 11:37:56 am
Kann es sein, dass in dem Upgrade.zip File noch ein SQL File fehlt ?

Bei mir war nur
upgrade1-0.sql
upgrade1-2.sql
upgrade1-3.sql

drinnen,
aber kein

upgrade1-1.sql
oder gibt es das nicht ?
hmm...

hartiberlin

*
#14
2018 June 15, 12:17:14 pm
Muss man noch irgendwas abschalten beim Upgrade ? Also z.B. SEF oder den ECL Mode oder so ?

Feline

*
#15
2018 June 15, 04:33:06 pm
Wenn du eine .htaccess hast, solltest du die vor umbenennen, z.B. in old_htaccess.
Wenn das update gelaufe ist, kannst du die wieder in .htacces umbenennen.
Wie du das mit dem Update (ohne FTP) hinbekommst habe ich dir in dem anderen topic geschrieben ..
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#16
2018 June 15, 05:25:32 pm
Hat leider nicht geklappt...

hartiberlin

*
#17
2018 June 15, 05:28:00 pm
Siehe Bild oben, er bleibt bei 0 % stehen und sagt, er hätte es schon gemacht auf 1.4

Iich hatte blöderweise erweiterte Debugginginformationen angeklickt also alle 3 kästen die da waren, angeklickt...

Aber FTP Daten wollte er jetzt nicht mehr...
aber irgendwie findet er die Pfade dann auch nicht mehr, weil die .htaccess ja nicht da ist...

Feline

*
#18
2018 June 15, 05:50:03 pm
Quote from: hartiberlin, 2018 June 15, 05:28:00 pmaber irgendwie findet er die Pfade dann auch nicht mehr, weil die .htaccess ja nicht da ist...
Ja die must du natürlich wieder aktivieren, wenn du SEF aktiviert hast.
Irgendwie habe ich den Eindruck, das du echt wenig Ahnung von PHP, Server Verwaltung, SQL etc. hast.
DAS sollte ein Forum Admin aber zumindest in Grundzügen verinnerlicht haben ....

Und ausserdem .. Auf dem bild steht doch, das die version 1.4 ist ..
Da gib es nicht mehr zu update ...
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#19
2018 June 15, 06:22:59 pm
Also sollte ich doch vor dem Update SEF deaktivieren ?
das hattest Du nirgendwo geschrieben...oder ich habe es nicht gesehen...??

Ich probiere das alles mal.
Danke.

Feline

*
#20
2018 June 15, 06:56:38 pm
Quote from: hartiberlin, 2018 June 15, 06:22:59 pmAlso sollte ich doch vor dem Update SEF deaktivieren ?
das hattest Du nirgendwo geschrieben...oder ich habe es nicht gesehen...??

Ich probiere das alles mal.
Danke.
Das MUSS nicht sein .. SEF wird ja nicht geladen beim Update ...
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#21
2018 June 15, 09:59:15 pm

Hi Feline,
speichert die Installation das noch irgendwo anders ab, als in der Datenbank, dass schon die Version 1.4 vorhanden ist ?

Ich hatte jetzt nochmal neu die 1.3 Datenbank hochgespielt ,
hatte aber alle Files vom 1.4 Upgrade schon in der Domain
und dann SEF ausgeschaltet, alle ECL settings ausgeschaltet,
dann .htaccess umbenannt in old_htaccess
und dann das gepatchte upgrade.php gestartet...
Aber er fängt nicht an, die Datenbank zu bearbeiten, bleibt bei 0 % stehen und
sagt:

PortaMx Forum Upgrade Utility
PortaMx           
Progress
  • Step 1: Login
0%
 
Your Forum is allready up to date.
The current version is PortaMx Forum 1.4

Also,
wie weiss, er dass er schon auf 1.4 ist, wenn die Tabellen alle noch von der 1.3 sind ??

Feline

*
#22
2018 June 15, 10:12:37 pm
Das steht in der Settings Tabelle ...
Da gib es einen Eintrag z.B:
    pmxVersion        PortaMx-Forum 1.3   
Und wenn da 1.4 steht macht er "natürlich" kein Update ...
Das müsstest du dann in 1.3 ändern ...
Many are stubborn in relation to the way, but less in relation to the target.

hartiberlin

*
#23
2018 June 15, 10:44:39 pm
Quote from: feline, 2018 June 15, 10:12:37 pmDas steht in der Settings Tabelle ...
Da gib es einen Eintrag z.B:
    pmxVersion        PortaMx-Forum 1.3   
Und wenn da 1.4 steht macht er "natürlich" kein Update ...
Das müsstest du dann in 1.3 ändern ...
Ja, da steht einmal Version 1.3 und einmal 1.4

Janz merkwürdig...
und ich kann die Tabelle mit PHP MyAdmin nicht editieren...
Es kommt da die Fehlermeldung:
Die aktuelle Markierung enthält keine eindeutige („unique") Spalte.
Gitter-Bearbeitungsfunktion, Kontrollkästchen, Bearbeiten, Kopieren und
Löschen von Links sind nicht verfügbar.

Also ich kann irgendwie nicht auf Bearbeiten gehen...
What a fuck....
Murphy´s law schlägt hier heute wieder extrem zu.... :-\  :-\  :-[  :-[  :-[

hartiberlin

*
#24
2018 June 15, 11:04:56 pm
Mit PhpMyAdim Verion 3.3 kann ich diesen Wert auf PMX Version ändern,
aber trotzdem zeigt mir das Upgrade.php wieder an, es sei schon Verion 1.4 installiert !!!!
Shit...

Kann es sein, dass in der Datenbank noch irgendwo steht, auf welche Datenbank er zugreifen soll ?
Habe nämlich da mehere zu liegen...
Aber es müsste doch eigentlich nur in der   Settings.php
stehen,
oder ?

Muss man die Settings.php.bak auch noch editieren für die neue Datenbank Adresse ??

* Shouts

Feline
2018 Aug. 21, 08:10:46 pm
Today we update our Forum to the Version 1.45
Feline
2018 Jun. 09, 07:54:13 pm
Today we update our Forum to Version 1.4
This release is full compatible with the EU GDPR
Feline
2018 Mar. 28, 11:56:21 am
Update for PortaMx 1.54 ecl released.
With this updates the Portal works with PHP 7.x and SMF 2.0.15
Feline
2018 Mar. 17, 10:35:03 pm
PortaMx Forum 1.3
released !

*
Feline
2017 Dec. 10, 04:30:54 am
Today we switched to PHP 7.2 and activate Opcode caching.
Fast .. Very fast *
Feline
2017 Mar. 03, 11:54:35 pm
Today we upgrade our old SMF 2.0 Forum to PortaMx Forum *

* Calendar

Su
Mo
Tu
We
Th
Fr
Sa
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
HolidaysDec 16: 3. Advent (de)