To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic

  • *Total Posts: 14963
  • *Total Topics: 2276
  • *Online Today: 46
  • *Most Online: 292
(2016 November 12, 09:37:31 am)

No admin controls?

Started by clothahump, 2010 November 29, 10:07:27 am

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

clothahump

2010 November 29, 10:07:27 am
Just installed, had to manually edit admin.php, install went smothly but no admin controls available when clicked on, any ideas?

feline

#1
2010 November 29, 02:14:06 pm
In this case, I think the installation is not correct ...

Fel
Many are stubborn in relation to the path, a few in relation to the target.

clothahump

#2
2010 November 29, 02:39:09 pm
That obvious, what is the fix????????

clothahump

#3
2010 November 29, 02:47:11 pm
This sucks, unable to upload .php file.

feline

#4
2010 November 29, 07:36:00 pm
You have to check if all PortaMx files exist and all modifications successfully applied.
More I can't say ..

Fel
Many are stubborn in relation to the path, a few in relation to the target.

clothahump

#5
2010 November 29, 09:51:13 pm
Can you provide list of files, locations and chmod settings???

feline

#6
2010 November 29, 10:57:15 pm
simple look at the archive .. the folder structure is the same as on your server.
And chmod ..  755 for folder, 644 for files is normally.

Fel
Many are stubborn in relation to the path, a few in relation to the target.

clothahump

#7
2010 November 29, 11:14:12 pm
Still nothing, checked all files and they are fine.

feline

#8
2010 November 30, 12:31:06 pm
You have checked all modifications?
I think no ...

Fel
Many are stubborn in relation to the path, a few in relation to the target.

clothahump

#9
2010 November 30, 12:51:43 pm
What modifications???

feline

#10
2010 November 30, 02:00:00 pm
Try the package parser for your SMF version and the PortaMx package ...
https://www.portamx.com/spage,install-parser/

Fel
Many are stubborn in relation to the path, a few in relation to the target.

clothahump

#11
2010 November 30, 02:46:31 pm
So why is this offered as a package if I then have to manually change all the files? it should be advertised differently so we know what we are letting our selves in for.

Norv

#12
2010 November 30, 02:56:36 pm
Automatic installation of packages works for most forums. We don't know why it didn't work for you, it may depend on your particular server configuration or other mods installed.
The point is, when that happens, one thing that can be done is to try to check yourself, to make sure that all edits that should have been done were indeed done.

Autopilot

#13
2010 November 30, 04:59:13 pm
Quote from: clothahump ,  2010 November 29, 10:07:27 am
Just installed, had to manually edit admin.php, install went smothly but no admin controls available when clicked on, any ideas?


I would suspect what ever you changed when you edited admin.php is the problem. It would help others if you told what version of SMF and PMX you are working with.
As Feline suggested perhaps not all the files were properly uploaded to your server. Simple fix would be to uninstall, then delete PMX. FTP to your server and manually delete all instance of PMX then re-install.

clothahump

#14
2010 December 02, 11:38:01 am
Looks like it was the manual edit as suggested in the install text, copied from parser and it seems to be working apart from no articles or categories?
No way to add new blocks, are these missing components an add on?

Norv

#15
2010 December 02, 09:24:51 pm
You can add new blocks...

So are you saying that you made a manual edit and what was missing before works now?

clothahump

#16
2010 December 02, 09:31:30 pm
Just found the silly little image to add a block but still unable to add categories or pages, this really is hard work compared to the other portals that are available.

[attachment deleted by admin]

spoogs

#17
2010 December 02, 10:40:57 pm
It's already been stated that some features are still under development... take a look at the 0.990 threads and you see that.

Pages can be created -  frankly if you take a few minute to read you'll find your way around just fine.

clothahump

#18
2010 December 02, 10:50:55 pm
Not a lot to read in the admin panel, have not seen anything stating pages and categories do not work.
It would help if it stated in the downloads area that only half of the portal works, what is the point in releasing something that does not do what it supposedly can? I have not got the time to keep messing around with incomplete bits of script.

b4pjoe

#19
2010 December 03, 12:11:11 am
It is as complete as any portal out there. Articles and categories are being added in the 1.0 version as has been stated on this forum. So finding they do not work on an earlier version does not make it incomplete.

If you are having trouble installing it, it is most likely because another mod has already changed some code that PortaMx needs to change. When you go to install it and any tests are unsuccessful you can click the small image to the left that will show you exactly what is failing but it will probably never work if you just go ahead and install it with errors. You can either uninstall the mod causing the conflict or make all changes to any files that have any errors manually. Not just the parts that show the errors because it will not make changes in that particular file if there are any errors, even changes that could be successful will not be made if there are errors in the other parts of the code for that file. Just stating you had to manually edit a file is not enough information for any one to help you. Give us the specifics. For example:

Quote from: clothahump ,  2010 November 29, 10:07:27 am
Just installed, had to manually edit admin.php, install went smothly but no admin controls available when clicked on, any ideas?


Why did you have to manually edit admin.php?

clothahump

#20
2010 December 03, 12:15:28 am
Because a line of commands could not be inserted automatically, I have checked all files and it now works.
I need to add pages and categories now, are there any instructions on how to achieve this on here?

b4pjoe

#21
2010 December 03, 01:23:12 am
Quote from: clothahump ,  2010 December 03, 12:15:28 am
Because a line of commands could not be inserted automatically, I have checked all files and it now works.
I need to add pages and categories now, are there any instructions on how to achieve this on here?


Categories are not implemented yet.

By pages I assume you mean single pages. Go to Block Manager/Single Pages and click the + button on the right side to create a new single page. The "Page name" that you give it will be part of the URL you use to access it. For example if you name your page name "my_single_page" the url would be

Code Select
http://www.yourforum.com/index.php?spage=my_single_page

Click any of the  buttons inside the editor to get help for that particular function.

clothahump

#22
2010 December 03, 10:52:52 am
Created a page but now when adding new ones they are just tacked on the end of the first page, this is getting extremely annoying.

spoogs

#23
2010 December 03, 02:07:46 pm
Are you asking for help or just complaining.

I'm sorry that Fel didnt sit with you and write this to YOUR specifications.

clothahump

#24
2010 December 03, 02:15:55 pm
Asking for help.