To use this website completely, it is necessary to store cookies on your computer.
 

* Navigator

Expand - Collapse

* Statistic

  • *Total Posts: 14939
  • *Total Topics: 2271
  • *Online Today: 8
  • *Most Online: 292
(2016 November 12, 09:37:31 am)

How do I make articles show on Frontpage?

Started by matthew, 2016 March 07, 01:09:06 pm

previous topic - next topic

0 Members and 0 Guests are viewing this topic.

matthew

2016 March 07, 01:09:06 pm
This is embarrassing. I can't see how to have all my articles appear on the front page. I figure I have to create a block, but the only article blocks I can see are Static Article and Static Category, but I want all articles from any category. Latest at the top and paginated would be good, too, if it's possible.

feline

#1
2016 March 09, 02:47:30 pm
Create a Category, then link your articles to the categry. Also you can create more categories, for more overview. links these as subcategory to the  Main category and sort in your articles.

Now create a category block on the frontpage, select you main category and save.
Now you can see the category (and - if enabled - all subcategires on the main category) and also the articles in it.

Done ...  ;)
Many are stubborn in relation to the path, a few in relation to the target.

matthew

#2
2016 March 09, 10:23:50 pm
Thanks, feline. :)

I've given that a try. I created a parent category called "Articles", and a child category called "Arduino". I created a couple of test articles and put them in the "Arduino" category. If I set the Static Category block to look at the parent category of "Articles", I don't see any articles. If I set the Static Category block to look at the child category "Arduino", I do see articles.

Is there some other setting to allow the parent category to show the child category articles?

Also, when I do see the articles, I only see them when I'm logged in as admin, not as guest. I have set all the block, categories and articles to Access Settings -> Guests, Regular Members (basically copied the Welcome block's access settings). Resolved. I tried this so many ways, I had forgotten to apply the view permission on the articles that time around. I still need to figure out why the categories won't show as above.

edit: completely fresh install of SMF 2.0.11 and PortaMX 1.54ecl. Nothing else installed.